Some Microsoft 365 Services are Unavailable
Resolved
Microsoft resolved the issues pertaining to Microsoft 365. Service has been restored. We apologize for the inconvenience.
Posted Sep 12, 2024 - 15:19 CDT
Identified
Microsoft is currently investigating an issue that affects some Microsoft 365 issues. You may experience slow response times or not be able to access certain resources e.g. Teams.

We will update this status when receive more information from Microsoft.
Posted Sep 12, 2024 - 09:19 CDT
This incident affected: Microsoft (Office) 365 (Outlook (Email), SharePoint (SSDLife), Teams).