Temporary Service Restrictions Due to MOREnet Cybersecurity Incident

Update

Our internet service provider (MOREnet) is experiencing a cybersecurity attack. This is impacting network services at SSD, as well as at some of our partner districts. To mitigate the effect, we are temporarily shutting off access to some internal services (Phoenix, ESI, Lawson, VPN) from being accessed outside SSD buildings.
We apologize for the inconvenience and disruption this situation causes.
Posted Mar 03, 2026 - 11:16 CST

Monitoring

Our internet provider, MoreNet, is experiencing a Distributed Denial of Service attack on their network that is targeted at one of their customers. This is affecting traffic on their network which as a trickle down effect is causing our connection to drop periodically. We will continue to monitor the situation and update as needed.
Posted Mar 03, 2026 - 10:20 CST
This incident affects: Special Education Information Management Systems (SEIMS) (Phoenix (Special Education Application), ESI) and Network, Telecommunications, Lawson.