Network and Phone Outage affecting some buildings

Resolved

We have resolved an incident related to the network and phones at Neuwoehner, Litzsinger and the Warehouse.

If you are still experiencing issues, please let us know. If we do not hear from you, your ticket will close automatically in the coming days.

Thank you!
Posted Jul 22, 2026 - 14:10 CDT

Monitoring

We have implemented a solution to resolve an incident with network and phones at Neuwoehner, Litzsinger and the Warehouse. Resources have been tested by the onsite technicians.

You may continue to monitor the situation for updates by visiting and/or subscribing to status.ssdmo.org.

Thank you!
Posted Jul 22, 2026 - 07:37 CDT

Investigating

We are currently investigating an incident related to the network and phones at Neuwoehner, Litzsinger and the Warehouse.

We will keep your ticket open for the duration of the incident.

You may continue to monitor the situation for updates by visiting and/or subscribing to status.ssdmo.org.

We apologize for the inconvenience.
Posted Jul 21, 2026 - 15:27 CDT
This incident affected: Network.