RingCentral Issue
Resolved
The issue with RingCentral was resolved.
Posted Nov 01, 2023 - 14:16 CDT
Update
We believe the issue with RingCentral has been resolved. We are continuing to monitor the situation in case there are any residual issues that need to be addressed. We apologize for any inconvenience.
Posted Oct 24, 2023 - 09:14 CDT
Monitoring
A fix is in the process of being implemented by RingCentral. We have advised users to restart their phones and/or devices. This is working for some, but not all users. We will continue to wait to get confirmation from RingCentral that the problem is completely resolved. We apologize for any inconvenience.
Posted Oct 23, 2023 - 15:41 CDT
Identified
There is an issue with RingCentral related to the account maintenance that took place this past weekend. Users who were a part of the maintenance may not have a functional account at the moment. We have been in contact with RingCentral and they are working on a resolution.
Posted Oct 23, 2023 - 09:06 CDT
This incident affected: Telecommunications.