Phoenix is down for some users

Update

Fixes were implemented on Wednesday afternoon that we believe have resolved the issue with intermittent access to Phoenix. We will continue to monitor the situation in the coming days in case the situation should return. We apologize for the inconvenience.
Posted Apr 04, 2025 - 14:55 CDT

Update

We are continuing to work through this issue with our internet service provider. We have continued to receive sporadic reports of staff being unable to access Phoenix and other SSD services.
Posted Apr 02, 2025 - 12:43 CDT

Monitoring

A fix has been implemented for users having intermittent access to Phoenix. We will continue to monitor and collect feedback from users.
Posted Mar 28, 2025 - 14:33 CDT

Update

We are still working with our internet service provider to resolve these issues. Unfortunately, we do not have an estimated time for resolution. We apologize for the inconvenience.
Posted Mar 28, 2025 - 08:37 CDT

Update

We have identified an issue with users being able to access some internally-hosted SSD services such as Phoenix, ESI and BeyondTrust. Access to these services may be intermittent.

We are working with an internet service provider to resolve these issues. Unfortunately, we do not have an estimated time for resolution. We apologize for the inconvenience.
Posted Mar 27, 2025 - 12:24 CDT

Update

We are still investigating an issue with access to some internally-hosted services such as Phoenix, ESI and BeyondTrust. Access to these services may be intermittent for users.
Posted Mar 25, 2025 - 14:55 CDT

Identified

There is an issue that has been identified that may affect some users ability to use Phoenix. We apologize for the inconvenience and will update this page when we have more information.
Posted Mar 24, 2025 - 15:24 CDT
This incident affects: Special Education Information Management Systems (SEIMS) (Phoenix (Special Education Application), ESI) and Miscellaneous.