We believe yesterday's disruption of service to the Atlassian product suite is now resolved. Jira Service Desk, Confluence and other products should be operating normally again. We apologize for the inconvenience.
Posted Oct 21, 2025 - 15:32 CDT
Monitoring
This disruption is due to a broader outage with Atlassian's cloud provider, AWS.
While the application is now accessible and partially functional, some features may still be slow or intermittently unavailable. Atlassian has confirmed they are actively working with AWS to resolve the issue and are closely monitoring the situation. They have not provided a specific timeline for full resolution but have assured us that restoring full service is their top priority.
We will continue to monitor the situation and share updates as we receive them. Thank you for your patience and understanding.
Posted Oct 20, 2025 - 14:34 CDT
Identified
Atlassian Cloud Services are currently experiencing an outage due to issues with their public cloud provider. The incident began around 07:56 UTC on October 20, 2025, and has affected multiple services including Jira Service Desk, Opsgenie, Authentication, Licensing, and more. Atlassian teams are actively working with the cloud provider to resolve the issue. Partial recovery has begun, and updates are being provided hourly or sooner.