Datacenter Maintenance Window - 27 September 2025

Scheduled for Sep 27, 07:00 - 19:00 CDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 18, 2025 - 11:24 CDT

Scheduled

Technology Services will be conducting a datacenter maintenance window Saturday, September 27th, 2025 from 7am to 7pm. During this time, hosted SSD services will have intermittent access while we apply patches and updates to our network and server infrastructure.
Posted Aug 18, 2025 - 11:22 CDT
This scheduled maintenance affects: Special Education Information Management Systems (SEIMS) (Phoenix (Special Education Application), ESI), Microsoft (Office) 365 (Outlook (Email), Teams), and Service Desk, Workforce Management (WFM), Lawson, Miscellaneous.