Microsoft 365 Services Unavailable

Resolved

This incident has been resolved. Thank you for your patience during the outage.
Posted Oct 30, 2025 - 11:14 CDT

Identified

Microsoft services maybe unavailable to some users across different web services that they offer. Microsoft has identified the potential issue and is working to mitigate the negative impact while keeping services online where they can. We will update this status with more information when they provide it.
Posted Oct 29, 2025 - 12:55 CDT
This incident affected: Microsoft (Office) 365 (Outlook (Email), SharePoint (SSDLife), Teams).