FinReporting Issues

Monitoring

The majority of the issues with FinReporting have been resolved. We are still working on one known issue related to one report that is run within FinReporting. We will continue to monitor the situation, and update with more information as needed.
Posted Feb 11, 2026 - 07:32 CST

Update

We are continuing to investigate issues relating to user access to FinReporting. We apologize for the inconvenience and will update as more information becomes available.
Posted Feb 10, 2026 - 08:56 CST

Investigating

We are aware of an issue affecting FinReporting access for users outside the District and are actively investigating. We will provide updates as soon as we have more information.
Posted Feb 09, 2026 - 07:52 CST
This incident affects: Miscellaneous.