Investigating HEART and HERO

Resolved

We have resolved an incident with HEART and HERO. If you are still experiencing issues, please let us know. If we do not hear from you, your ticket will close automatically in the coming days.

Thank you.
Posted Jul 06, 2026 - 13:00 CDT

Investigating

We are currently investigating an incident with HEART and HERO. We will keep your ticket open for the duration of the incident.

You may continue to monitor the situation for updates by visiting and/or subscribing to status.ssdmo.org.

We apologize for the inconvenience.
Posted Jul 06, 2026 - 09:44 CDT
This incident affected: Homebound Applications (Hero, Heart).