Network Outage

Resolved

This incident was resolved. We apologize for the inconvenience today.
Posted Mar 10, 2026 - 18:19 CDT

Investigating

We are currently experiencing a network outage that is affecting most users. Resources are beginning to come back up, but some will take longer than others (ie. Phoenix).

We'll update this when we have more information.
Posted Mar 10, 2026 - 14:55 CDT
This incident affected: Network.