ESI - Outage

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 08:18 CDT

Monitoring

Access to ESI has been restored. We will continue to monitor the situation.
Posted Apr 29, 2026 - 07:37 CDT

Investigating

We are currently investigating an issue with ESI. It is currently inaccessible. We apologize for the inconvenience.
Posted Apr 29, 2026 - 07:31 CDT
This incident affected: Special Education Information Management Systems (SEIMS) (ESI).