Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 09, 2025 - 19:00 CDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 03, 2025 - 14:22 CDT
Scheduled
Phoenix and ESI will be temporarily unavailable starting at 7:00 PM on Tuesday, September 9, 2025, due to scheduled maintenance. The applications are expected to be accessible again later that same night.
This upgrade resolves inconsistent search results for goals in the Staff Management screen and fixes an administration error that prevented the removal of progress reporting calendar dates. Release Notes - https://ssdmo.atlassian.net/wiki/x/UICHkg
All users must clear their browser cache after this release, use the steps in the link below to clear cache from the browser then restart the computer after the cache has been cleared. https://ssdmo.atlassian.net/wiki/x/3QBxB
Posted Sep 03, 2025 - 14:20 CDT
This scheduled maintenance affected: Special Education Information Management Systems (SEIMS) (Phoenix (Special Education Application), ESI).