Ring Central Mobile Application
Resolved
This incident has been resolved.
Posted Jun 05, 2023 - 10:58 CDT
Update
The fix has been implemented by RingCentral, and they are no longer monitoring this as an active issue.
Posted Mar 22, 2023 - 07:46 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 15, 2023 - 10:05 CDT
Investigating
A portion of customers may be experiencing issues with failed outbound SMS messages to some mobile providers. Ring Central's Operations teams are working with these providers to resolve the issues with SMS functionality.
Posted Mar 15, 2023 - 10:03 CDT
This incident affected: Telecommunications.