Intermittent Phone Outages

Resolved

This incident is resolved at this time. Thank you for your patience.
Posted Apr 15, 2026 - 14:50 CDT

Monitoring

A fix has been put into place to address this issue. We are currently monitoring the status of the phone system and will update this if anything changes.
Posted Apr 15, 2026 - 09:42 CDT

Investigating

We are currently investigating an issue that is causing intermittent phone outages across the district. We are working with our vendors to help identify this. We'll update StatusPage when we receive more information.
Posted Apr 15, 2026 - 08:29 CDT
This incident affected: Telecommunications.