Microsoft 365 - Users may be unable to access or use some Microsoft 365 services and features
Resolved
This incident, and other related incidents, have been resolved by Microsoft. We apologize for any inconvenience this issue may have caused.
Posted Dec 03, 2024 - 14:14 CST
Update
Microsoft has implemented fixes for the service issue and continues to monitor results. Users may continue to experience intermittent issues with Microsoft Outlook, Office 365 and Teams until Microsoft deems the issue resolved. We apologize for any inconvenience and will update as more information becomes available.
Posted Nov 26, 2024 - 08:56 CST
Monitoring
Microsoft has implemented fixes and is seeing progress in restoration from today's incident. We anticipate this issue will continue into the evening hours and should be resolved by Tuesday morning. We will continue to monitor progress. We apologize for any inconvenience and will update as more information becomes available.
Posted Nov 25, 2024 - 15:32 CST
Identified
Microsoft is working to implement a fix to the issues that all customers are experiencing. Until the fix is applied, access to Microsoft Outlook, Office 365 and Teams may continue to be sporadic. We apologize for any inconvenience and will update as more information becomes available.
Posted Nov 25, 2024 - 13:10 CST
Investigating
Microsoft is currently investigating an issue where users may be unable to access or use some Microsoft 365 services and features. This would include Microsoft Outlook, Office 365 and Teams. This incident is impacting all Microsoft customers. We apologize for any inconvenience and will update as more information becomes available.
Posted Nov 25, 2024 - 10:12 CST
This incident affected: Microsoft (Office) 365 (Outlook (Email), Teams).