Document Self Service and Other Services Unavailable
Resolved
The incident that took place with Document Self-Service has been resolved. All of the services taken offline yesterday have been restored. We apologize for the inconvenience.
Posted Feb 27, 2024 - 08:27 CST
Identified
We have identified a new issue from the outage this morning with the server that hosts Document Self-Service. This is a larger issue requiring immediate action. As a result, Document Self-Service, MHC Document Express and Transfinder are being taken offline.

We are working as quickly as possible to get services restored. We apologize for any inconvenience.
Posted Feb 26, 2024 - 12:11 CST
Monitoring
A fix has been implemented to restore services to Document Self Service. We are monitoring for any further outages.
Posted Feb 26, 2024 - 09:00 CST
Investigating
We are currently investigating an issue with Document Self Service where users are unable to access files. We will update StatusPage when we receive more information.
Posted Feb 26, 2024 - 08:22 CST
This incident affected: Lawson and Miscellaneous.