North Garage Dispatch Building Fiber Cut

Resolved

Fiber was spliced and repaired. Phones and network are operational.
Posted Aug 06, 2025 - 10:48 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 31, 2025 - 11:38 CDT

Identified

Due to construction in the parking lot in the North Garage area, the network fiber feeding the dispatch building has been cut.  We are working with contractors to coordinate the fix, but as of this moment, we do not have an ETA on repair.  We will be making updates about this issue on our Status Page.  

https://status.ssdmo.org/
Posted Jul 31, 2025 - 11:36 CDT
This incident affected: Network and Telecommunications.