Update

We are still investigating the issue with Docuware. Access and operation within the platform is slow. We are reaching out to a third-party for additional support.
Posted Jan 14, 2026 - 12:51 CST

Investigating

We are currently investigating an issue with Docuware. We are planning on rebooting the Docuware server this morning at 10:30am. This may impact staff in Human Resources, Finance and Student Records. We apologize for the inconvenience and will update as more information becomes available.
Posted Jan 14, 2026 - 10:08 CST
This incident affects: Miscellaneous.