North Tech and Northview Power Outage

Resolved

Power has been restored to the area, and all network services are back up.
Posted Apr 28, 2026 - 09:16 CDT

Identified

Due to power outages, North Tech and Northview are without power. Both sites will be closed today as the district is waiting on support from Ameren to restore power.
Posted Apr 28, 2026 - 07:04 CDT
This incident affected: Network and Telecommunications.