Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 06, 2026 - 17:30 CDT
Scheduled
Good morning,
Technology Services is scheduled to perform network maintenance on critical network equipment. We are planning a 2 hour outage, from 5:30pm to 7:30pm Wednesday, May 6th, to make the configuration changes that are required. During this time, SSD's network will be intermittently down while configs are pushed to equipment. This will disrupt the following services:
Phones Internet Phoenix ESI Heart Hero DocuWare ESS FinReporting
Once the configurations are pushed to the equipment and changes are saved, network service will be restored.
If you have any concerns or questions, please reach out to the Technology Service Desk by submitting a ticket at technologyservices@ssdmo.org or by calling 314-989-8686
Posted May 05, 2026 - 13:11 CDT
This scheduled maintenance affected: Special Education Information Management Systems (SEIMS) (Phoenix (Special Education Application), ESI) and Network, Miscellaneous.