Phone Outage

Resolved

This incident has been resolved. Thank you for your patience.
Posted Jun 04, 2025 - 13:46 CDT

Monitoring

A fix has been implemented that should resolve this issue. We'll be monitoring for any changes at this time.
Posted Jun 04, 2025 - 08:30 CDT

Investigating

We are currently investigating an issue that's causing phones across the district to be unavailable. We'll update this status when we have more information available.
Posted Jun 04, 2025 - 07:39 CDT
This incident affected: Telecommunications.