RingCentral Issue

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 07:00 CDT

Investigating

We are currently investigating an issue with RingCentral. The issue may impact the ability for users to use the service with physical phones.
Posted Apr 28, 2026 - 13:31 CDT
This incident affected: Telecommunications.