Encore Reports is Down
Resolved
We have resolved this incident. Access to Encore Reports is restored.
Posted Oct 27, 2023 - 10:31 CDT
Update
We are continuing to investigate this issue.
Posted Oct 27, 2023 - 10:30 CDT
Investigating
We are currently investigating an issue that affects Encore Reports. We will update you when we have more information to share.
Posted Oct 27, 2023 - 08:08 CDT
This incident affected: Miscellaneous.