Some District Services are Unavailable

Resolved

This incident has been resolved. Thank you for your patience.
Posted Mar 13, 2025 - 10:22 CDT

Monitoring

A fix has been implemented and we're currently monitoring the results.
Posted Mar 11, 2025 - 08:30 CDT

Investigating

We are currently investigating an issue that may affect some District services. This may include Infor, Phoenix and other hosted services. Not all staff maybe affected by this issue. We'll update this when we have more information.
Posted Mar 11, 2025 - 08:00 CDT
This incident affected: Lawson.