Issue with accessing Microsoft Outlook

Resolved

Microsoft was able to resolve the issue. We apologize for the inconvenience.
Posted Jul 11, 2025 - 08:59 CDT

Update

Microsoft has implemented a fix to resolve the issue preventing some users from accessing Microsoft Outlook on the web. Some users may have regained access, other users may still not have access. Microsoft anticipates all users regaining access in the next few hours. We apologize for the inconvenience and will update as more information becomes available.
Posted Jul 10, 2025 - 11:46 CDT

Identified

Microsoft has reported an incident that is preventing some users from accessing Microsoft Outlook on the web. Microsoft is currently applying fixes to resolve the issue. We apologize for the inconvenience and will update as more information becomes available.
Posted Jul 10, 2025 - 09:30 CDT
This incident affected: Microsoft (Office) 365 (Outlook (Email)).