SSD Portal / Privacy Warning for Some Services
Resolved
Technology Services has resolved the incident that affected the SSD Portal and some other services. Thank you for your patience during this time.
Posted Sep 13, 2024 - 07:56 CDT
Update
We are still working on resolving the privacy warning for some SSD services. At the moment, the SSD Portal is still unavailable. We are working on a resolution to the issue. We apologize for the inconvenience.
Posted Sep 12, 2024 - 15:21 CDT
Investigating
Technology Services is investigating an issue affecting some services like Portal, ESI, and Document Self Service. You may see a privacy warning when accessing these. As a workaround, try using Google Chrome and click 'Advanced' and then click the link to proceed anyway.

We'll provide updates as more information becomes available
Posted Sep 12, 2024 - 07:40 CDT
This incident affected: Miscellaneous.