Phoenix, ESI and Finreporting are down

Resolved

This incident has been resolved.
Posted Feb 02, 2026 - 11:10 CST

Investigating

We are currently investigating an issue affecting the functionality of Phoenix, ESI and Finreporting. We'll update this status when we have more information available.
Posted Feb 02, 2026 - 10:24 CST
This incident affected: Special Education Information Management Systems (SEIMS) (Phoenix (Special Education Application), ESI).