Finreporting Is Currently Down
Resolved
We have discovered the root cause of this issue and have resolved it. Finreporting should have all options available to all users at this time.

Thank you for your patience.

Technology Services
Posted Jan 12, 2022 - 09:34 CST
Investigating
We are currently investigating an issue that causes menu options to be missing from Finreporting. This incident will be updated when we have more information or have identified the cause of the issue.

Thank you for your patience.

Technology Services
Posted Jan 12, 2022 - 08:59 CST
This incident affected: Miscellaneous.